[Scons-users] Segmentation faults in scons-2.2.0

Chris Irvine cirvine1 at telus.net
Thu Aug 15 21:07:40 EDT 2013

Here’s what I get.

$ scons -H

Memory fault (core dumped)

$ cd scratch

$ mkdir test

$ cd test

$ ll

total 8

0 drwxr-xr-x 1 Owner None 0 Aug 15 18:58 .

8 drwxrwx--- 1 Owner None 4096 Aug 15 18:58 ..

$ scons -H

Memory fault (core dumped)

$ scons

Memory fault (core dumped)

$ scons --debug=pdb

Memory fault (core dumped)



From: scons-users-bounces at scons.org [mailto:scons-users-bounces at scons.org]
On Behalf Of Dirk Bächle
Sent: Thursday, August 15, 2013 1:05 AM
To: scons-users at scons.org
Subject: Re: [Scons-users] Segmentation faults in scons-2.2.0

Hi Chris,

On 15.08.2013 05:58, Chris Irvine wrote:

I wish to run Madagascar and I have python- running on my Interix 6.1
system. Madagascar requires scons. The Madagasscar configure script tried
to load scons automatically and failed to configure Madagascar. I tried to
manually install scons using the python setup.py install command. It seemed
to work with no error messages. However, when I run scons, it always ends
with a segmentation error and a core dump (even with scons –c command). As
well, I don’t see a file created named site_scons.


Any suggestions on how to narrow down the problem? Are there ways to
analyze the core dump?

I'm sorry to hear that you seem to have trouble getting SCons to work
properly. Here are a few first suggestions to narrow down the problem a bit:

1.) Does "scons -H" crash too?
2.) What output do you get from "scons" when you call it in an empty
folder (no SConstruct, no files, no anything)?
3.) SCons has a "--debug=pdb" option which re-runs it in the debugger. You
might get a backtrace there, and see in which
module/method the segfault happens.

Best regards,


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://four.pairlist.net/pipermail/scons-users/attachments/20130815/15af50ad/attachment.htm

More information about the Scons-users mailing list