[Scons-users] Segmentation faults in scons-2.2.0

Chris Irvine cirvine1 at telus.net
Wed Aug 14 23:58:38 EDT 2013

I wish to run Madagascar and I have python- running on my Interix 6.1
system. Madagascar requires scons. The Madagasscar configure script tried
to load scons automatically and failed to configure Madagascar. I tried to
manually install scons using the python setup.py install command. It seemed
to work with no error messages. However, when I run scons, it always ends
with a segmentation error and a core dump (even with scons -c command). As
well, I don't see a file created named site_scons.

My Interix system acts a bit like Cygwin in that a call to 'pwd' will give
the Windows 7 file location rather than the Interix one. It could easily be
an incorrect addressing feature. The man pages and scripts were correctly
put into usr/local/man and /bin respectively.

My system is

bash-3.2$ uname -X

System = Interix

Node = Irvine-HP

Release = 6.1

Version = 10.0.7063.0

Machine = genuineintel

Processor = Intel64_Family_6_Model_42_Stepping_7

HostSystem = Windows

HostRelease = 6.1

HostVersion = SP1


Any suggestions on how to narrow down the problem? Are there ways to
analyze the core dump?



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://four.pairlist.net/pipermail/scons-users/attachments/20130814/c4e2aabf/attachment.htm

More information about the Scons-users mailing list